News

Galactic Civilizations III -- v2.8 Legacy build

Posted on Wednesday, April 11, 2018

Hello,

We introduced a major patch to Galactic Civilizations III (v3.0).  We understand that some people may wish to continue their old save games without being impacted by the changes.  

To continue playing v2.8, please do the following:

  • Select Galactic Civilizations III in your Steam Library list
  • Right-click and select Properties
  • Select the BETAS tab
  • From the dropdown, select "version 2.8"  and click Close (if you don't see this option, restart Steam)

Note this older version is NOT compatible with Intrigue.